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1 VERSION CONTROL 

Version Approved Date Approved Date 
1.0 Rob Clark 19/02/2016   
     
     
     
     
     

 

2 THE PURPOSE OF THE DOCUMENT 

 
The Revit content is intended to be used by experienced Autodesk Revit users.  The purpose of this 
guide is to support the user in working with the content on new and existing projects.   

Revit content produced by Excitech can contain the following, however not all content will cotain every 
point listed here, 

• A managed level of detail (“LOD 200” (AIA) or above) 3D geometric representation of the 
product.  

• CAD appearance data (Coarse and Fine detail)  

• Revit material asset data were applicable  

• Appearance data including visualisation images were available.  

• Product identification information  

• Revit MEP electrical connections were applicable  

• COBie UK 2012 data as required by the NBS BIM Object Standard 

• IFC data as required by the NBS BIM Object Standard 

• Uniclass  classification system data as required by the NBS BIM Object Standard 

• NBS specification data as required by the NBS BIM Object Standard  
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3 INSTALLING INTO REVIT CONTENT 

To install either a single or multiple products into another Autodesk Revit project or template please 
follow these instructions.   

3.1 Unpacking the content 

1. Use a program like Winzip or Alzip to open the downloaded .ZIP compressed file. 

2. If material image files are included, extract (consult your software help files on how to extract files 

if you are unsure) the “Materials” folder to the following directory on your computer, 

C:\LocalRVT\Excitech\Materials.    

3. Extract the RFA file(s) to your content library.  We suggest not extracting the files to the Metric 

Libraries that come with Revit as these can be manipulated during installs, repairs and service 

packing of your Revit software.  

3.2 Loading component content (RFA files) 
Loadable component families is any content distributed within a Revit RFA file.  

1. Open the Autodesk Revit  project or template file that you wish to load the content into  

2. The method of loading content differs depending on the category of component; 

a. For general components such as FFE  - Go to the Home* tab > Component > Place a 

Component 

b. For windows – Go to the Home* tab > Window  

c. For doors – Go to the Home* tab > Door 

d. For MEP components, choose the correct tool under the Home* tab 

e. For Structural components, choose the correct tool under the Home* tab 

 

(*=in full Revit, the Home tab is split into three seperate tabs, Architecture, Systems and 

Structure)  

 

 
 

3. On the Modify tab > Load Family 

 

4. Navigate to the folder you extracted your RFA into > Select the file > Open 
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5. Ensure you have the correct component selected in the Type selector (type “PP” if you can’t see 

the properties tab) 

 

6. Now place your component in the drawing view.  

3.3 Loading system and material families (RVT) 
System families is any content distributed within a Revit RVT file.  

1. Open the Autodesk Revit  project or template file that you wish to copy the materials into 

2. Ensure no other models are open. 

3. Open up a Floor Plan view, typically the Ground floor is best and maximise the view. 

4. Use Close Hidden on the Windows tab to close all other views 

 

5. Open the Revit project file that containts the System family and / or material that you have 

downloaded.   

6. Select the system or material host (such as floor, ceiling, wall, roof) that you wish to include in 

your project.  

 

7. Left click on the wall and Hold down CNTRL key and press the letter C, or go to the Modify | 

Walls tab and select the Copy to Clipboard tool 

 

8. Switch to the project that you want to copy the wall into.  

Tip. Use CTRL-TAB to quickly switch between open windows.  

9. Hold down the CTRL key and press the letter V, or go to the Modify tab and select the Paste 

option 
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10. This will place the object onto your cursor.  Place with a left click in open space within your 

project. 

11. Once placed you can delete them again by selecting them and then pressing the DELETE key 

on your keyboard. 

12. The next step depends on the type of content you added 

a. To place the system, such as a floor, wall, ceiling or roof, go to the appropriate tool and 

select your object from the Type selector 

b. To view a material that you have added, go to Materials on your Manage tab 

 

You should now be able to find the materials in your material list for use within any 

suitable family, such as systems like floors, walls, ceilings and roofs.  They can also be 

added to component families (RFAs) that have been loaded into your project.  

3.4 Common placement issues  
If you are unable to see the content after placement, the below check list should prove useful, 

1. Check the category is visually switched on in the selected view (Visual Graphics settings).    

2. Ensure other categories that could be preventing the viewing of the content are switched off.  

3. Make sure no visual filters are affecting visibility 

 

4. Make sure the view range is not preventing visibility.   In ceiling plans, the cut plane should be 

under the ceiling level.  

 

5. Ensure the crop is not preventing the visibility.   

6. In a 3D view, check that the section box is activated.  Note that section boxes can be hidden both 

by Element and Category 
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7. Check that there is not an obstacle in the way.  Switch to Wireframe to remove all surfaces and 

ensure you can see the content.  If you can, then you need to hide the object that is causing the 

obstruction before switching back to a Hidden Line, Shaded or Rendered View 

 

8. If your content is hosted, such as “face based”, “ceiling based” etc. Check have suitable surface 

like a ceiling present in the view.   If not, use a reference plane with a name applied to host the 

content by selecting ‘Place on Work Plane’  

9. Ensure the content is not flipped into the surface.  If it is, use the “flip” to switch the side of the 

surface it is on: 

 

3.5 Viewing Materials  
Content may have custom materials embedded to ensure the correct representation.  If you are unsure if 
these were included, speak to the content provider. 
 
 To view these materials, follow the below steps: 

1. Ensure you have extracted the materials as instructed in “Unpacking the Content”.    If you have 

not done this, go to these instructions, follow these and then restart the Revit software. 

2. Switch to the Realistic Mode to see the materials 
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3. Custom materials should now be visible  

  

4. If custom materials are still not visible then ensure you have extracted the materials as instructed 

in “Unpacking the Content” and then restart the software.  If you cannot extract the materials go 

to C:\LocalRVT\Excitech\Materials, go to Manage > Materials 

5. Find the correct material and double click 

 

6. Go to the Appearance Asset and select  Expand the“Generic” section, you will notice a .   Click 

on this: 

7. Navigate to the folder you extracted the materials to and click the image and click Open 

 

8. Repeat this procedure for all materials 

9. Switch to the Realistic Mode to see the materials 

 

Custom materials should now be visible. 
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4 PARAMETERS INCLUDED IN THE DATASET 

4.1 Included Parameter Protocols 
Content produced by Excitech usually contains the following protocols as required by the NBS BIM 
Object Standard:   

1. COBie UK 2012 FM Export    

2. National Building Specification (NBS) 

3. Uniclass 2 

4. IFC 

Hard coded parameters are built into the Autodesk Revit database and are present (by default) in all RVT 
files.  Shared parameters are created by the user and ensure data is stored in the same location within 
the database for many items of the same type; even if installed from many file locations.  

4.2 Utilised Revit Hard Coded Parameters 
The following Autodesk Revit hard coded parameters have been utilised: 

Parameter Name Description Revit Units 

Comments General comments  Text 
Description Product marketing description  Text 
Manufacturer Manufacturer of the content Text 
Model  Product codes Text 
Name (Type) Full product name Text 
Type (Material) Autodesk material designations, i.e. Plastic  Text 
URL Website URL listing further information on the 

product 
URL 

 

4.3 Specification Parameters 
For further information on NBS Product Specification, please visit -
http://www.thenbs.com/corporate/about.asp 

The following parameters follow the guidance as issued in the NBS BIM Object Standard  

For further information on Uniclass 2, please visit the HM Government’s BIM Task Group website -  
http://www.bimtaskgroup.org/uniclass2/ 

Parameter Name Description Revit Units 
Author Name of the person or organisation that authored 

the object (in this case Excitech Ltd) 
Text 

BIMObjectName Alphanumeric text name that identifies 
and represents the BIM object within the BIM 
platform 

Text 

ProductInformation URL to further product information available on the 
manufactuerers website 

URL 

ManufacturerURL Manufacturers main website URL URL 

NBS Description Alphanumeric value of the appropriate NBS 
clause title from 
http://www.nationalbimlibrary.com/api/ 

Text 

NBSReference Alphanumeric value of the appropriate NBS clause 
reference from 
http://www.nationalbimlibrary.com/api/. 

Text 

Revision Current revision of the content.  Filled to whole 
values, i.e. 1, 2, 3 

Number 
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Uniclass2 Value of the appropriate Uniclass2 classification 
code and description. Uniclass can be found at 
http://www.cpic.org.uk/uniclass2/ 

Text 

Uniclass1 Value of the appropriate Uniclass1.4 classification 
code and description. Uniclass can be found at 
http://www.cpic.org.uk/uniclass1/ 

Text 

Version Property completed with a numerical value, stated 
as a whole number, representing 
the sequence of the object publication 

Text 

 

4.4 COBie Parameters 
COBie is the information exchange specification specified by a number of clients, including those utilising 
the processes included in BSi PAS1192-2/3/4.  It is part of the Government Construction Strategy 
published May 2011 which calls for implementation in 2016. 

For further information on COBie and for an example COBie spreadsheet, please visit the HM 
Government BIM Task Groups website - http://www.bimtaskgroup.org/cobie-uk-2012/. The 
buildingSMARTalliance also has information including instructional videos online at 
http://www.nibs.org/?page=bsa_cobie  

The following parameters follow the guidance as issued in the NBS BIM Object Standard v1.1 

The following COBie Parameters are utilised: 

Parameter Name Description Revit Units 

Name Name of the product Text 

Category 
Products are categorised using the Uniclass 2 
classification system 

Text 

Description 
A condensed version of our product description  
Review product specification data for more detail 

Text 

   

AssetType The COBie approved values are fixed or moveable   Text 

Manufacturer Manufactuers name Text 

Model Number Product model number Text 

WarrantyGuarantorParts The parts gurantor Text 

   

WarrantyDurationParts The duration in years of a parts warranty Number 

   

WarrantyGuarantorLabor The labor gurantor  Text 

   

WarrantyDurationLabor Duration set in years Number 

   

WarrantyDurationUnit The unit value of our warranty durations is years Text 

ReplacementCost The cost of replacing the item Text 

ExpectedLife The expected life of the item  

DurationUnit All durations are shown in years Text 

WarrantyDescription Desciprtion of any warranty terms Text 

NominalLength Filled out in millimetres if available Length 

NominalWidth Filled out in millimetres if available Length 

NominalHeight Filled out in millimetres if available Length 

ModelReference Name of the product Text 

Shape Description of product shape if available Text 

Size Overall size in millimetres if available Text 

Colour Description of general product colour if available Text 

Finish Description of finishes if available  Text 

Grade Description of standard grading if available Text 

Material Description of materials if available Text 

Constituents Description of parts within the products.   Text 

Features Description of any product features if available Text 
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AccessibilityPerformance 
Description of any known accessibility issues if 
available 

Text 

SuistainabilityPerformance Environmental statement Text 

CodePerformance 
Description of any relevant standards or codes if 
available 

Text 

 
The following properties are also included as instance parameters and would be completed by the asset 
management team for each individual installation: 

• ‘SerialNumber’ property completed with an alphanumeric default value ‘n/a’ 

• ‘InstallationDate’ property completed with the default value ‘1900-12-31T23:59:59’ 

• ‘WarrantyStartDate’ property completed with the default value ‘1900-12-31T23:59:59’ 

• ‘TagNumber’ property completed with an alphanumeric default value ‘n/a’ 

• ‘Barcode’ property completed with an alphanumeric default value ‘n/a’ 

• ‘AssetIdentifier’ property completed with an alphanumeric default value ‘n/a’ 

4.5 Industry Foundation Class (IFC) 
 
The IFC file type is a platform neutral, open file format specification that is not controlled by a single 
vendor or group of vendors.  It is an object-based file format with a data model developed by 
buildingSMART to facilitate interoperability in the architecture, engineering and construction (AEC) 
industry.  It is a commonly used collaboration format in Building information modelling (BIM) based 
projects. The IFC model specification is open and available.    In theory, it should enable you to use data 
in other BIM packages such as Graphisoft ArchiCAD.   

Autodesk Revit allows for IFC export using an in-built exporter.  IFC is a rapidly developing schema and 
several new releases of the IFC exporter are often developed within a single Revit software release 
cycle.  If you are required to export to IFC we recommend you update the IFC exporter included in Revit 
to the latest addition.  These tools can be found on the Autodesk Exchange Store - 
http://apps.exchange.autodesk.com/RVT/en/Home/Index and also 
http://sourceforge.net/projects/ifcexporter/  

The content is supplied with paramters which are aligned to the IFC Property Sets (PSETS) required 
within the schema.   These differ between types of elements, so a light fixture is required to have different 
properties in IFC schema to a plug socket.  Below we list the common property sets, which includes the 
IFCExportAs, which is the IFC category.  A full description of PSETs go to, http://www.buildingsmart-
tech.org/ifc/IFC2x3/TC1/html/index.htm and then > Property Sets > PSD Alphabetical Index > then click 
on the individual PSET.    
 
Please note the owner of the content, the content hosts and the authors are able to offer further advice or 
support on using this content in software other than Autodesk Revit.   

Parameter Name Description Revit Units 
IfcExportType IfcExportType to define the PredefinedType of the specific IFC type Text 

IfcExportAs IfcExportAs for the specific IFC Entity or type to be assigned to Text 

 

5 CONTACT INFORMATION 

Please review contact information as included in the Revit Content. 


